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 Important Information

Warranty
The NI PCI-6703/6704 and NI PXI-6704 are warranted against defects in materials and workmanship for a period of one year from the date of 
shipment, as evidenced by receipts or other documentation. National Instruments will, at its option, repair or replace equipment that proves to 
be defective during the warranty period. This warranty includes parts and labor. 

The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, due to defects 
in materials and workmanship, for a period of 90 days from date of shipment, as evidenced by receipts or other documentation. National 
Instruments will, at its option, repair or replace software media that do not execute programming instructions if National Instruments receives 
notice of such defects during the warranty period. National Instruments does not warrant that the operation of the software shall be 
uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of the package before 
any equipment will be accepted for warranty work. National Instruments will pay the shipping costs of returning to the owner parts which are 
covered by warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed for technical 
accuracy. In the event that technical or typographical errors exist, National Instruments reserves the right to make changes to subsequent 
editions of this document without prior notice to holders of this edition. The reader should consult National Instruments if errors are suspected. 
In no event shall National Instruments be liable for any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS ANY WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF 
NATIONAL INSTRUMENTS SHALL BE LIMITED TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER. NATIONAL INSTRUMENTS WILL NOT BE LIABLE FOR 
DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY 
THEREOF. This limitation of the liability of National Instruments will apply regardless of the form of action, whether in contract or tort, including 
negligence. Any action against National Instruments must be brought within one year after the cause of action accrues. National Instruments 
shall not be liable for any delay in performance due to causes beyond its reasonable control. The warranty provided herein does not cover 
damages, defects, malfunctions, or service failures caused by owner’s failure to follow the National Instruments installation, operation, or 
maintenance instructions; owner’s modification of the product; owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, 
flood, accident, actions of third parties, or other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, 
recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National 
Instruments Corporation.

Trademarks
National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation. Refer to the Terms of Use section 
on ni.com/legal for more information about National Instruments trademarks.

Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Members of the National Instruments Alliance Partner Program are business entities independent from National Instruments and have no 
agency, partnership, or joint-venture relationship with National Instruments.

Patents
For patents covering National Instruments products/technology, refer to the appropriate location: Help»Patents in your software, 
the patents.txt file on your media, or the National Instruments Patent Notice at ni.com/patents.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS
(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL OF 
RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL COMPONENTS IN 
ANY LIFE SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO CAUSE SIGNIFICANT 
INJURY TO A HUMAN.

(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS CAN BE 
IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL POWER SUPPLY, 
COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE FITNESS, FITNESS OF COMPILERS 
AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION, INSTALLATION ERRORS, SOFTWARE AND 
HARDWARE COMPATIBILITY PROBLEMS, MALFUNCTIONS OR FAILURES OF ELECTRONIC MONITORING OR CONTROL 
DEVICES, TRANSIENT FAILURES OF ELECTRONIC SYSTEMS (HARDWARE AND/OR SOFTWARE), UNANTICIPATED USES OR 
MISUSES, OR ERRORS ON THE PART OF THE USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS THESE ARE 
HEREAFTER COLLECTIVELY TERMED “SYSTEM FAILURES”). ANY APPLICATION WHERE A SYSTEM FAILURE WOULD 
CREATE A RISK OF HARM TO PROPERTY OR PERSONS (INCLUDING THE RISK OF BODILY INJURY AND DEATH) SHOULD 
NOT BE RELIANT SOLELY UPON ONE FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM FAILURE. TO AVOID 
DAMAGE, INJURY, OR DEATH, THE USER OR APPLICATION DESIGNER MUST TAKE REASONABLY PRUDENT STEPS TO 
PROTECT AGAINST SYSTEM FAILURES, INCLUDING BUT NOT LIMITED TO BACK-UP OR SHUT DOWN MECHANISMS. 
BECAUSE EACH END-USER SYSTEM IS CUSTOMIZED AND DIFFERS FROM NATIONAL INSTRUMENTS' TESTING 
PLATFORMS AND BECAUSE A USER OR APPLICATION DESIGNER MAY USE NATIONAL INSTRUMENTS PRODUCTS IN 
COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT EVALUATED OR CONTEMPLATED BY NATIONAL 
INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS ULTIMATELY RESPONSIBLE FOR VERIFYING AND VALIDATING 
THE SUITABILITY OF NATIONAL INSTRUMENTS PRODUCTS WHENEVER NATIONAL INSTRUMENTS PRODUCTS ARE 
INCORPORATED IN A SYSTEM OR APPLICATION, INCLUDING, WITHOUT LIMITATION, THE APPROPRIATE DESIGN, 
PROCESS AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.
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About This Manual

This manual contains information about using the NI PCI-6703/6704 and 

NI PXI-6704 devices. The NI 6703/6704 devices are designed for precise 

DC setpoint applications and provide general-purpose digital I/O.

If you are using NI-DAQ 8.6 or later, refer to the DAQ Getting Started 

Guide, which you can download at ni.com/manuals. The DAQ Getting 

Started Guide offers NI-DAQ users step-by-step instructions for installing 

software and hardware, configuring channels and tasks, and getting started 

developing an application.

Conventions

The following conventions appear in this manual:

<> Angle brackets that contain numbers separated by an ellipsis represent 

a range of values associated with a bit or signal name—for example, 

AO <3..0>.

» The » symbol leads you through nested menu items and dialog box options 

to a final action. The sequence File»Page Setup»Options directs you to 

pull down the File menu, select the Page Setup item, and select Options 

from the last dialog box.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to 

avoid injury, data loss, or a system crash. When this symbol is marked on a 

product, refer to the Read Me First: Safety and Radio-Frequency 

Interference document for information about precautions to take.

When symbol is marked on a product, it denotes a warning advising you to 

take precautions to avoid electrical shock.

When symbol is marked on a product, it denotes a component that may be 

hot. Touching this component may result in bodily injury.

bold Bold text denotes items that you must select or click in the software, such 

as menu items and dialog box options. Bold text also denotes parameter 

names.
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italic Italic text denotes variables, emphasis, a cross-reference, or an introduction 

to a key concept. Italic text also denotes text that is a placeholder for a word 

or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 

keyboard, sections of code, programming examples, and syntax examples. 

This font is also used for the proper names of disk drives, paths, directories, 

programs, subprograms, subroutines, device names, functions, operations, 

variables, filenames, and extensions.

NI 6703/6704 This phrase refers to any device in the NI 6703/6704 family.

Related Documentation

Each application software package and driver includes information about 

writing applications for taking measurements and controlling measurement 

devices. The following references to documents assume you have 

NI-DAQ 8.6 or later, and where applicable, version 7.0 or later of the 

NI application software.

NI-DAQmx for Windows
The DAQ Getting Started Guide describes how to install your NI-DAQmx 

for Windows software, how to install your NI-DAQmx-supported DAQ 

device, and how to confirm that your device is operating properly. Select 

Start»All Programs»National Instruments»NI-DAQ»DAQ Getting 

Started Guide.

The NI-DAQ Readme lists which devices are supported by this version of 

NI-DAQ. Select Start»All Programs»National Instruments»NI-DAQ»

NI-DAQ Readme.

The NI-DAQmx Help contains general information about measurement 

concepts, key NI-DAQmx concepts, and common applications that are 

applicable to all programming environments. Select Start»All Programs»

National Instruments»NI-DAQ»NI-DAQmx Help.
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NI-DAQmx for Linux
The DAQ Getting Started Guide describes how to install your 

NI-DAQmx-supported DAQ device and confirm that your device is 

operating properly.

The NI-DAQ Readme for Linux lists supported devices and includes 

software installation instructions, frequently asked questions, and known 

issues.

The C Function Reference Help describes functions and attributes.

The NI-DAQmx for Linux Configuration Guide provides configuration 

instructions, templates, and instructions for using test panels.

Note All NI-DAQmx documentation for Linux is installed at /usr/local/natinst/

nidaqmx/docs.

LabVIEW
If you are a new user, use the Getting Started with LabVIEW manual 

to familiarize yourself with the LabVIEW graphical programming 

environment and the basic LabVIEW features you use to build data 

acquisition and instrument control applications. Open the Getting Started 

with LabVIEW manual by selecting Start»All Programs»National 

Instruments»LabVIEW»LabVIEW Manuals or by navigating to the 

labview\manuals directory and opening LV_Getting_Started.pdf.

Use the LabVIEW Help, available by selecting Help»Search the 

LabVIEW Help in LabVIEW, to access information about LabVIEW 

programming concepts, step-by-step instructions for using LabVIEW, and 

reference information about LabVIEW VIs, functions, palettes, menus, and 

tools. Refer to the following locations on the Contents tab of the LabVIEW 

Help for information about NI-DAQmx:

• Getting Started»Getting Started with DAQ—Includes overview 

information and a tutorial to learn how to take an NI-DAQmx 

measurement in LabVIEW using the DAQ Assistant.

• VI and Function Reference»Measurement I/O VIs and 

Functions—Describes the LabVIEW NI-DAQmx VIs and properties.

• Taking Measurements—Contains the conceptual and how-to 

information you need to acquire and analyze measurement data 

in LabVIEW, including common measurements, measurement 

fundamentals, NI-DAQmx key concepts, and device considerations.
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LabWindows/CVI
The Data Acquisition book of the LabWindows/CVI Help contains 

measurement concepts for NI-DAQmx. This book also contains Taking an 

NI-DAQmx Measurement in LabWindows/CVI, which includes 

step-by-step instructions about creating a measurement task using the DAQ 

Assistant. In LabWindows™/CVI™, select Help»Contents, then select 

Using LabWindows/CVI»Data Acquisition.

The NI-DAQmx Library book of the LabWindows/CVI Help contains 

API overviews and function reference for NI-DAQmx. Select Library 

Reference»NI-DAQmx Library in the LabWindows/CVI Help.

Measurement Studio
If you program your NI-DAQmx-supported device in Measurement Studio 

using Visual C++, Visual C#, or Visual Basic .NET, you can interactively 

create channels and tasks by launching the DAQ Assistant from MAX or 

from within Visual Studio .NET. You can generate the configuration code 

based on your task or channel in Measurement Studio. Refer to the DAQ 

Assistant Help for additional information about generating code. You also 

can create channels and tasks, and write your own applications in your 

ADE using the NI-DAQmx API.

For help with NI-DAQmx methods and properties, refer to the NI-DAQmx 

.NET Class Library or the NI-DAQmx Visual C++ Class Library included 

in the NI Measurement Studio Help. For general help with programming in 

Measurement Studio, refer to the NI Measurement Studio Help, which is 

fully integrated with the Microsoft Visual Studio .NET help. To view 

this help file in Visual Studio. NET, select Measurement Studio»

NI Measurement Studio Help.

To create an application in Visual C++, Visual C#, or Visual Basic .NET, 

follow these general steps:

1. In Visual Studio .NET, select File»New»Project to launch the New 

Project dialog box.

2. Find the Measurement Studio folder for the language you want to 

create a program in.

3. Choose a project type. You add DAQ tasks as a part of this step.
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ANSI C without NI Application Software
The NI-DAQmx Help contains API overviews and general information 

about measurement concepts. Select Start»All Programs»National 

Instruments»NI-DAQ»NI-DAQmx Help.

The NI-DAQmx C Reference Help describes the NI-DAQmx Library 

functions, which you can use with National Instruments data acquisition 

devices to develop instrumentation, acquisition, and control applications. 

Select Start»All Programs»National Instruments»NI-DAQ»

NI-DAQmx C Reference Help.

.NET Languages without NI Application Software
With the Microsoft .NET Framework version 1.1 or later, you can use 

NI-DAQmx to create applications using Visual C# and Visual Basic .NET 

without Measurement Studio. You need Microsoft Visual Studio 

.NET 2003 or Microsoft Visual Studio 2005 for the API documentation to 

be installed.

The installed documentation contains the NI-DAQmx API overview, 

measurement tasks and concepts, and function reference. This help is fully 

integrated into the Visual Studio .NET documentation. To view the 

NI-DAQmx .NET documentation, go to Start»Programs»National 

Instruments»NI-DAQ»NI-DAQmx .NET Reference Help. Expand 

NI Measurement Studio Help»NI Measurement Studio .NET 

Class Library»Reference to view the function reference. Expand 

NI Measurement Studio Help»NI Measurement Studio .NET Class 

Library»Using the Measurement Studio .NET Class Libraries to view 

conceptual topics for using NI-DAQmx with Visual C# and Visual 

Basic .NET.

To get to the same help topics from within Visual Studio, go to Help»

Contents. Select Measurement Studio from the Filtered By drop-down 

list and follow the previous instructions.

Device Documentation
The NI 6703/6704 Specifications, available at ni.com/manuals contains 

detailed hardware specifications for NI 6703/6704 devices.

NI 6703/6704 Calibration Procedure for NI-DAQmx, available at 

ni.com/manuals, contains instructions for calibrating the NI 6703/6704 

for PCI/PXI/CompactPCI using NI-DAQmx.
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NI 6703/6704 Calibration Procedure for Traditional NI-DAQ, available at 

ni.com/manuals, contains instructions for calibrating the NI 6703 for 

PCI or NI 6704 for PCI/PXI/CompactPCI using Traditional NI-DAQ 

(Legacy).

The following documents also contain information you may find helpful:

• NI Developer Zone tutorial, Field Wiring and Noise Considerations 

for Analog Signals, located at ni.com/zone

• PCI Local Bus Specification Revision 2.2

• PICMG CompactPCI 2.0 R3.0 Core Specification

• PXI Specification Revision 2.0, available from www.pxisa.org

Documentation for supported devices and accessories, including PDF

and help files describing device terminals, specifications, features, 

and operation are on the NI-DAQmx media that includes Device 

Documentation. Insert the media, open the Device Documentation 

directory, and double-click the Device Documents shortcut for your 

language to find, view, and print device documents.

Training Courses
If you need more help getting started developing an application with 

NI products, NI offers training courses. To enroll in a course or obtain 

a detailed course outline, refer to ni.com/training.

Technical Support on the Web
For additional support, refer to ni.com/support or zone.ni.com.

Note You can download these documents at ni.com/manuals.

DAQ specifications and some DAQ manuals are available as PDFs. You 

must have Adobe Acrobat Reader with Search and Accessibility 5.0.5 or 

later installed to view the PDFs. Refer to the Adobe Systems Incorporated 

Web site at www.adobe.com to download Acrobat Reader. Refer to the 

National Instruments Product Manuals Library at ni.com/manuals for 

updated documentation resources.



© National Instruments Corporation 1-1 NI 6703/6704 User Manual

1
Introduction

This chapter describes the NI 6703/6704 devices, lists what you need to get 

started, describes optional software, equipment, and custom cables, and 

explains how to unpack your device.

For information about installing and configuring your device, refer to the 

DAQ Getting Started Guide at ni.com/manuals.

About the NI 6703/6704

The NI 6703/6704 devices are precise DC setpoint devices for PCI and 

PXI. The NI 6703 devices have 16 voltage output channels. The NI 6704 

devices have 16 voltage output channels and 16 current output channels 

for a total of 32 analog output channels. The NI 6703/6704 devices have 

eight digital I/O lines.

You can use the NI 6703/6704 devices in a wide variety of DC setpoint 

and digital I/O applications. With the NI 6703/6704 devices, your PC 

system can serve as a digital I/O system controller for laboratory testing, 

production testing, and industrial process monitoring and control. 

These devices can do the following:

• Generate experimental stimuli

• Generate analog functions

• Connect to a variety of signal types, including:

– Electromechanical relays

– LEDs

– Optically isolated, solid-state relays and I/O module mounting 

racks

– Voltage and current excitation for precision transducers

– Current excitation for precision transducers (NI 6704 only)

For detailed specifications for the NI 6703/6704 devices, refer to the 

NI 6703/6704 Specifications, available at ni.com/manuals.
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Using PXI with CompactPCI

The ability to use PXI-compatible products with standard CompactPCI 

products is an important feature of PXI Specification Revision 2.0. If you 

use a PXI-compatible plug-in device in a standard CompactPCI chassis, 

you are unable to use PXI-specific functions, but you can still use the basic 

plug-in device functions. 

The CompactPCI specification permits vendors to develop sub-buses that 

coexist with the basic PCI interface on the CompactPCI bus. Compatible 

operation is not guaranteed between CompactPCI devices with different 

sub-buses nor between CompactPCI devices with sub-buses and PXI 

devices. The standard implementation for CompactPCI does not include 

these sub-buses. The NI PXI-6704 works in any standard CompactPCI 

chassis adhering to the PICMG CompactPCI 2.0 R3.0 core specification.

What You Need to Get Started

To set up and use your NI 6703/6704 device, you will need the following:

❑ One of the following devices:

– NI PCI-6703

– NI PCI-6704

– NI PXI-6704

❑ One of the following software packages and documentation:

– NI-DAQ 7.4 or later

– LabVIEW for Windows

– LabWindows/CVI for Windows

– Measurement Studio

– ANSI C without NI Application Software

– .NET Languages without NI Application Software

❑ PC with a free PCI slot or PXI chassis with a free slot

❑ 68-pin cable (SH68-68-D1)

❑ 68-pin terminal block (SCB-68)
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Optional Equipment

National Instruments offers a variety of products to use with your 

NI 6703/6704, including cables, connector blocks, and other accessories, 

as follows:

• Cables and cable assemblies, shielded and ribbon

• Connector blocks, shielded and unshielded screw terminals

For more specific information about these products, visit ni.com/

products.

Custom Cabling
Follow these guidelines if you want to develop your own cable:

• Route the analog lines separately from the digital lines. 

• When using a cable shield, use separate shields for the analog and 

digital halves of the cable. Failure to do so results in noise coupling 

into the analog signals from transient digital signals.

National Instruments offers cables and accessories for you to

prototype your application or to use if you frequently change module 

interconnections. For more specific information about these products, visit 

ni.com/products.

For more information on the connectors used for DAQ devices, refer to the 

KnowledgeBase document, Specifications and Manufacturers for Board 

Mating Connectors at ni.com/support.
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2
Signal Connections

This chapter provides connection instructions for the signals on your 

NI 6703/6704 device I/O connector.

Caution Connections that exceed any of the maximum ratings of input or output signals 

on the NI 6703/6704 device can damage the device and the computer. Maximum input 

ratings for each signal are given in this chapter under the discussion of that signal. National 

Instruments is not liable for any damages resulting from any incorrect signal connections.

I/O Connector Pin Assignments

Figures 2-1 and 2-2 show the I/O connector pin assignments for the 

NI 6703/6704 devices.
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Figure 2-1.  NI 6703 Connector Pin Assignments

1 No Connect when using the SH68-68-D1 cable.
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Figure 2-2.  NI 6704 Connector Pin Assignments

1 No Connect when using the SH68-68-D1 cable.
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AO 31 (I)

P0.7

P0.6

P0.5

P0.4

P0.3

P0.2

P0.1

P0.0

+5 V

AO 21 (I)

AO GND 5/21

AO 4 (V)

AO 19 (I)

AO GND 3/19

AO 2 (V)

AO 17 (I)

AO GND 1/17

AO 0 (V)

V = Voltage

I = Current

NC = No Connect
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Signal Connection Descriptions
 

Signal Name Reference Direction Description

P0.<0..7> D GND Input or 

Output

Digital I/O lines—Line 7 is the MSB and 

Line 0 is the LSB.

AO <0..15> (V) AO GND Output Voltage output channels.

AO <16..31> (I) AO GND Output Current output channels on the NI 6704.

No connects on the NI 6703.

AO GND 

<0/16..15/31>

— — Analog Output Grounds—Each ground pin is 

shared between one voltage and one current 

channel. These pins are connected to the 

NI 6703/6704 device analog ground plane. 

All NI 6703/6704 device ground planes 

connect to the computer system’s ground 

signal.

AO GND — — Additional pins connected to analog output 

ground. If you are using a SH68-68-D1 cable, 

these signals are not connected.

D GND — — Digital Ground—These pins are connected to 

the NI 6703/6704 device digital ground plane. 

All NI 6703/6704 device ground planes 

connect to the computer system’s ground 

signal.

+5 V D GND Output +5 V—This pin is connected to the computer 

system’s +5 VDC supply through a 

self-resetting circuit breaker.

NC — — Do not connect external circuitry to these pins.

RESERVED — — Reserved for future use.
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Analog Output Signal Connections

This section describes how to make connections for voltage and current 

outputs. The NI 6704 has both voltage and current outputs. The NI 6703 

has voltage outputs only. A 68-pin cable such as the SH68-68-D1 cable is 

required. Figure 2-3 shows how to connect the voltage channel as a voltage 

output.

Figure 2-3.  Voltage Output Connections

Voltage Output
You can connect a floating load to your NI 6703/6704 device at the voltage 

output channel.

Caution Because NI 6703/6704 devices are not electrically isolated from high voltages, a 

load with high common-mode voltages can damage the devices. National Instruments is 

not liable for any damages resulting from any such signal connections. 

The NI 6703/6704 device has a bipolar voltage range of –10.1 to +10.1 V. 

Maximum load current is ±10.1 mA for 16-bit linearity.

Power-On State
All voltage outputs are at their user-defined values to full accuracy within 

1 s of power-on board reset. Before this time, the voltage outputs can float 

to unspecified values. Take this behavior into account when connecting 

external devices to the NI 6703/6704.

Floating Load

AO GND

A

±10.1 V

AO n (V)

NI 6703/6704

Load
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NI 6704 Current Output
You can connect a floating or grounded load to your NI 6704 device at the 

current output channel. You do not need an external floating power supply 

to complete the controlled current loop. You can control the current loop 

from 0.1 to 20.2 mA. The compliance for the current loop is 0 V to 

10 VDC.

Note The voltage is not clamped at 10 V. If the current supplied to the load generates a 

voltage greater than 10 V, the device will generate a voltage greater than 10 V.

Caution Because the NI 6704 is not electrically isolated from high voltages, a load with 

high common-mode voltages can damage the NI 6704. National Instruments is not liable 

for any damages resulting from any such signal connections. 

Figure 2-4 shows how to connect a current channel as a current output.

Figure 2-4.  Current Output Connections

Because each current channel shares a ground line with a voltage channel, 

try to minimize the effect of the return current from your current channel 

on the voltage that you are outputting on your voltage channel. For 

example, if you output 20 mA on a current channel and return that current 

to the NI 6704 device along the shared ground line in a cable with an 

AO GND

AO n (I)

NI 6704

0.1 to 20.2 mA

Load
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impedance of 0.1 Ω, the voltage output will drop 2 mV on the voltage 

channel sharing the ground line. You can avoid this problem in the 

following ways:

• Use a shorter cable to minimize the impedance of the shared 

ground line.

• Use separate wiring for voltage channel and current channel ground 

lines return to minimize common ground impedance.

• Use different pairs of voltage and current channels to keep your 

sensitive voltage outputs separate from your higher output current 

channels.

Power-on State
All current outputs are within ± 1.1 mA maximum of their user-defined 

values within 0.5 s of power-on board reset. The current outputs will settle 

to their user-defined values to full accuracy within 7 s of power-on board 

reset. Take this behavior into account when connecting external devices to 

the NI 6704.

Digital I/O Signal Connections

Figure 2-5 illustrates example signal connections for three typical digital 

I/O applications.

Figure 2-5.  Example Digital I/O Connections

TTL Signal

LED

R

P0.<0..7>

NI 6703/6704

I/O Connector

Switch

+5 V

+5 V

D GND

Line 2

Line 1

Line 0
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In Figure 2-5, Line 0 is configured for digital output; Lines 1 and 2 are 

configured for digital input. 

Digital input applications include receiving TTL signals and sensing 

external device states such as the switch in Figure 2-5. Digital output 

applications include sending TTL signals and driving external devices such 

as the LED shown in Figure 2-5.

Note The NI 6703/6704 devices allow line-by-line direction control of digital I/O 

connections.

Refer to the NI 6703/6704 Specifications, available at ni.com/manuals, 

for a list of the digital I/O signal ratings.

Power-on State
At power on, all of the DIO lines on the NI 6703/6704 devices are 

configured as input lines.

Power Connections

Pin 1 on the I/O connector is connected to the +5 V supply from the PCI or 

PXI bus power supply. This pin is referenced to D GND and can supply 

power to external circuitry. The +5 V supply has a total of 0.75 A available.

Power rating............................................0.75 A at +5 V ±10%, 

+4.55 to +5.25 VDC at 0.75 A

The +5 V power supply has a self-resetting protection circuit breaker in 

series. If the circuit breaker protection is activated, remove the circuit 

causing the heavy current load and the circuit breaker will reset itself. 

For more information on these output pins, refer to the NI 6703/6704 

Specifications, available at ni.com/manuals.

Caution Never connect these +5 V power pins directly to ground or to any other voltage 

source on your NI 6703/6704 device or any other device. Doing so can damage your device 

and your computer system. National Instruments is not liable for damage resulting from 

such a connection.
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3
Hardware Overview

This chapter contains an overview of the hardware functions on the 

NI 6703/6704. The block diagram in Figure 3-1 illustrates the key 

functional components of the NI 6703/6704.

Figure 3-1.  NI 6703/6704 Block Diagram
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Bus Interface Circuitry

The bus interface circuitry monitors the PCI or PXI bus. If the bus address 

matches the NI 6703/6704 device address, the board is enabled and the 

corresponding register on the NI 6703/6704 is accessed.

Flash Memory/DAC Control

The NI 6703/6704 devices have one 16-bit DAC that is time-division 

multiplexed to create all the output channels. Each channel has a 

track-and-hold circuit to maintain the channel value between DAC updates. 

On the NI 6703, the DAC is multiplexed to create 16 voltage outputs and 

two calibration channels. On the NI 6704, the DAC is multiplexed to create 

16 voltage outputs, 16 current outputs, and four calibration channels.

Data is stored in Flash memory. The Flash memory/DAC control reads 

the DAC channel data stored in the Flash memory and updates the DAC 

periodically. The Flash memory/DAC control also controls the analog 

demultiplexing circuits to route the DAC output to the correct analog output 

channel. You can choose to save Flash memory data so that the current 

output values will become the power-on states. For information about how 

to set the power-on states, refer to the Setting the Power-On States for 

Software-Timed Digital I/O Devices topic in the NI-DAQmx Help.

Digital I/O Control

The NI 6703/6704 devices have eight digital I/O lines configured as one 

8-bit port. You can configure each line independently as an input or output. 

The DIO lines have 16 mA of sink capability and 16 mA of source 

capability. All digital lines are TTL-compatible. At power on, all digital 

lines are configured as inputs.

Temperature Sensor

The onboard temperature sensor measures the air temperature flowing over 

the board. This sensor is positioned near the onboard precision voltage 

reference, which can be affected by extreme temperatures. This sensor has 

a serial digital interface.
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4
Calibration

This chapter discusses the calibration options for the NI 6703/6704. 

Calibration is the process of minimizing output errors by making small 

circuit adjustments. There are two calibration channels used to make 

adjustments to the voltage channels on the NI 6703/6704. The NI 6704 has 

two additional channels used to make adjustments to the current channels.

Internal or Self-Calibration

The NI 6703/6704 devices perform continuous self-calibration. In addition 

to the accessible analog output channels, there are internal calibration 

channels that are scanned and refreshed with all the output channels. There 

are two of these calibration channels for the voltage outputs: the voltage 

offset channel and the voltage gain channel. 

There are also two calibration channels for the current outputs on the 

NI 6704: the current offset channel and the current gain channel. The 

outputs of these calibration channels are continuously compared to onboard 

references, and the 16-bit DAC offset and gain are adjusted to minimize

the errors in the calibration channels. Since NI 6703/6704 devices 

have excellent channel-to-channel matching of offset and gain errors, 

minimizing the errors in the calibration channels also minimizes the 

errors for all the voltage and current outputs.

External Calibration

The only calibration adjustment you must make is to adjust the values of 

the calibration channels to account for time- or temperature-related drift

of the onboard reference. These calibration values are loaded into Flash 

memory at factory calibration. You do not need to adjust them for at least 

one year after the date of factory calibration unless you are operating your 

device at an extreme temperature.

To perform an external calibration, refer to the NI 6703/6704 Calibration 

Procedure for NI-DAQmx.
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A
Common Questions

This appendix contains commonly asked questions and their answers 

relating to usage and special features of the NI 6703/6704.

Analog Output

How fast does the NI 6703 sample channels?

The NI 6703 devices have one 16-bit DAC that is time-division multiplexed 

to create 16 voltage output and two calibration channels. The channels are 

sampled at a rate of 50 µs per channel, meaning a channel can change value 

a maximum of 0.9 ms after it has been updated by software. 

How fast does the NI 6704 sample channels?

The NI 6704 devices have one 16-bit DAC that is time-division multiplexed 

to create 16 voltage output, 16 current output, and four calibration 

channels. The channels are sampled at a rate of 50 µs per channel, meaning 

a channel can change value a maximum of 1.8 ms after it has been updated 

by software.
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B
Technical Support and 
Professional Services

Visit the following sections of the award-winning National Instruments 

Web site at ni.com for technical support and professional services:

• Support—Technical support at ni.com/support includes the 

following resources:

– Self-Help Technical Resources—For answers and solutions, 

visit ni.com/support for software drivers and updates, 

a searchable KnowledgeBase, product manuals, step-by-step 

troubleshooting wizards, thousands of example programs, 

tutorials, application notes, instrument drivers, and so on. 

Registered users also receive access to the NI Discussion Forums 

at ni.com/forums. NI Applications Engineers make sure every 

question submitted online receives an answer.

– Standard Service Program Membership—This program 

entitles members to direct access to NI Applications Engineers 

via phone and email for one-to-one technical support as well as 

exclusive access to on demand training modules via the Services 

Resource Center. NI offers complementary membership for a full 

year after purchase, after which you may renew to continue your 

benefits. 

For information about other technical support options in your 

area, visit ni.com/services, or contact your local office at 

ni.com/contact. 

• Training and Certification—Visit ni.com/training for 

self-paced training, eLearning virtual classrooms, interactive CDs, 

and Certification program information. You also can register for 

instructor-led, hands-on courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 

technical resources, or other project challenges, National Instruments 

Alliance Partner members can help. To learn more, call your local 

NI office or visit ni.com/alliance.
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• Declaration of Conformity (DoC)—A DoC is our claim of 

compliance with the Council of the European Communities using 

the manufacturer’s declaration of conformity. This system affords 

the user protection for electromagnetic compatibility (EMC) and 

product safety. You can obtain the DoC for your product by visiting 

ni.com/certification.

• Calibration Certificate—If your product supports calibration, 

you can obtain the calibration certificate for your product at 

ni.com/calibration.

If you searched ni.com and could not find the answers you need, contact 

your local office or NI corporate headquarters. Phone numbers for our 

worldwide offices are listed at the front of this manual. You also can visit 

the Worldwide Offices section of ni.com/niglobal to access the branch 

office Web sites, which provide up-to-date contact information, support 

phone numbers, email addresses, and current events.
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Glossary

Symbol Prefix Value

n nano 10–9

µ micro 10– 6

m milli 10–3

k kilo 103

M mega 106

G giga 109

Symbols

° Degrees.

– Negative of, or minus.

Ω Ohms.

/ Per.

% Percent.

± Plus or minus.

+ Positive of, or plus.

A

A Amperes.

A/D Analog-to-digital.

ANSI American National Standards Institute.

AO GND Analog output ground signal.
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B

bit One binary digit, either 0 or 1.

bus The group of conductors that interconnect individual circuitry in a 

computer. Typically, a bus is the expansion vehicle to which I/O or other 

devices are connected.

C

C Celsius.

channel Pin or wire lead to which you apply or from which you read the analog or 

digital signal. Analog signals can be single-ended or differential. For digital 

signals, you group channels to form ports. Ports usually consist of either 

four or eight digital channels.

D

D/A Digital-to-analog.

DAC D/A converter.

DAQ Data acquisition—(1) Collecting and measuring electrical signals from 

sensors, transducers, and test probes or fixtures and inputting them to a 

computer for processing. (2) Collecting and measuring the same kinds of 

electrical signals with A/D and/or DIO boards plugged into a computer, and 

possibly generating control signals with D/A and/or DIO boards in the 

same computer.

DC Direct current.

device A plug-in data acquisition board, card, or pad that can contain multiple 

channels and conversion devices. Plug-in boards, PCMCIA cards, and 

devices such as the DAQPad-1200, which connects to your computer 

parallel port, are all examples of DAQ devices.

DIO Digital input/output.
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DLL Dynamic Link Library—A software module in Microsoft Windows 

containing executable code and data that can be called or used by Windows 

applications or by other DLLs. Functions and data in a DLL are loaded and 

linked at run time when they are referenced by a Windows application or 

other DLLs. 

drivers/driver software Software that controls a specific hardware device such as a DAQ board.

E

EEPROM Electrically Erasable Programmable Read-Only Memory (ROM) that can 

be erased (usually by ultraviolet light exposure) and reprogrammed.

F

function A set of software instructions executed by a single line of code that may 

have input and/or output parameters and returns a value when executed.

G

GND Ground signal or bit.

H

hardware The physical components of a computer system, such as the circuit boards, 

plug-in boards, chassis, enclosures, peripherals, cables, and so on.

hex Hexadecimal.

Hz Hertz—The number of scans read or updates written per second.

I

I/O Input/output—The transfer of data to/from a computer system involving 

communications channels, operator interface devices, and/or data 

acquisition and control interfaces.

IC Integrated circuit.
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in. Inches.

INL Integral Nonlinearity—A measure in LSB of the worst-case deviation from 

the ideal A/D or D/A transfer characteristic of the analog I/O circuitry.

interrupt A computer signal indicating that the CPU should suspend its current task 

to service a designated activity.

interrupt level The relative priority at which a device can interrupt.

IOH Current, output high.

IOL Current, output low.

K

KB Kilobytes—1,024 bytes when referring to memory.

L

LED Light-emitting diode.

LSB Least significant bit.

M

m Meters.

max Maximum.

min Minimum.

MSB Most significant bit.
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N

NC Not connected.

NI-DAQ National Instruments driver software for DAQ hardware.

noise An undesirable electrical signal—Noise comes from external sources such 

as the AC power line, motors, generators, transformers, fluorescent lights, 

soldering irons, CRT displays, computers, electrical storms, welders, radio 

transmitters, and internal sources such as semiconductors, resistors, and 

capacitors. Noise corrupts signals you are trying to send or receive.

O

operating system Base-level software that controls a computer, runs programs, interacts with 

users, and communicates with installed hardware or peripheral devices.

P

PCI Peripheral Component Interconnect—A high-performance expansion bus 

architecture originally developed by Intel to replace ISA and EISA. It has 

achieved widespread acceptance as a standard for PCs and workstations, 

and offers a theoretical maximum transfer rate of 132 Mbytes/s. 

port (1) A communications connection on a computer or a remote controller. 

(2) A digital port, consisting of four or eight lines of digital input and/or 

output.

ppm Parts per million.

PXI PCI eXtensions for Instrumentation—A rugged, open system for modular 

instrumentation based on CompactPCI, with special mechanical, electrical, 

and software features. 
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R

RAM Random access memory.

resolution The smallest signal increment that can be detected by a measurement 

system. Resolution can be expressed in bits, in proportions, or in percent 

of full scale. For example, a system has 12-bit resolution, one part in 

4,096 resolution, and 0.0244% of full scale.

RTSI Real-Time System Integration.

S

s Seconds.

settling time The amount of time required for a voltage to reach its final value within 

specified limits.

slot A position where a module can be inserted into the PCI bus.

T

transfer rate The rate, measured in bytes/s, at which data is moved from source to 

destination after software initialization and set up operations; the maximum 

rate at which the hardware can operate.

TTL Transistor-transistor logic.

typ Typical.

U

update The output equivalent of a scan. One or more analog or digital output 

samples. Typically, the number of output samples in an update is equal to 

the number of channels in the output group. For example, one pulse from 

the update clock produces one update which sends one new sample to every 

analog output channel in the group. 
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V

V Volts.

VDC Volts direct current.

VI Virtual Instrument—(1) A combination of hardware and/or software 

elements, typically used with a PC, that has the functionality of a classic 

stand-alone instrument. (2) A LabVIEW software module (VI), which 

consists of a front panel user interface and a block diagram program.

W

W Watts.
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custom cabling, 1-3

D
D GND signal (table), 2-4

Declaration of Conformity (NI resources), B-2

diagnostic tools (NI resources), B-1

digital I/O

example connections (figure), 2-7

hardware overview, 3-2

power-on state, 2-8

signal connections, 2-7

documentation
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S
self-resetting protection circuit breaker, 2-8

signal connections, 2-1

analog output
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I/O connector

pin assignments, 2-1

NI 6703 (figure), 2-2

NI 6704 (figure), 2-3

signal connection descriptions 

(table), 2-4

power connections, 2-8

software (NI resources), B-1

specifications, xi

support, technical, B-1

T
technical support, xii, B-1

temperature sensor, 3-2

training, xii

training and certification (NI resources), B-1

troubleshooting (NI resources), B-1

V
voltage output

power-up condition, 2-5

signal connections, 2-5

voltage output connections (figure), 2-5

W
Web resources, B-1
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