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These release notes contain instructions for installing the LabVIEW FPGA 

Module, configuring FPGA devices, and selecting execution targets. This 

document also provides exercises to introduce you to FPGA VIs and host 

VIs. Refer to the list of resources at the end of this document for more 

information about developing applications with the FPGA Module.
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What You Need to Get Started

This section contains a list of items you need before you can install the 

FPGA Module and develop a custom hardware solution with a National 

Instruments Reconfigurable I/O device, which also is known as an FPGA 

device.

❑ The following NI software packages:

– LabVIEW 7.0 CD

– LabVIEW Real-Time Module 7.0 CD if you want to control or 

monitor the FPGA device in real-time

– National Instruments Device Drivers CD

– LabVIEW FPGA Module 1.0 CD

❑ An FPGA device, like the NI PXI-7831R, and its documentation

❑ PXI/CompactPCI chassis and controller

Upgrading from the LabVIEW FPGA Pioneer System

If you installed the LabVIEW FPGA Pioneer System, you must uninstall 

Xilinx ISE and all NI software before you can install LabVIEW 7.0 and the 

FPGA Module 1.0. Complete the following steps to uninstall Xilinx ISE 

and NI software. 

1. Select Start»Settings»Control Panel»Add/Remove Programs to 

open the Add/Remove Programs dialog box.

2. Select Xilinx ISE from the Currently installed programs list and 

click the Change/Remove button. Follow the directions on the screen.

3. Select NI Software from the Currently installed programs list in the 

Add/Remove Programs dialog box and click the Change button. 

4. Uninstall NI-VISA, NI-RIO, and any other NI device drivers that you 

installed.

5. Uninstall NI LabVIEW, NI LabVIEW FPGA, NI LabVIEW 

Real-Time, and any other NI beta software that you installed.

6. Restart the computer.

Installing the LabVIEW FPGA Module

Complete the following steps to set up a development computer with 

LabVIEW, the LabVIEW Real-Time Module, the appropriate NI device 

drivers, and the LabVIEW FPGA Module. The development computer is a 

PC or PXI system running Windows and on which you install the 
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LabVIEW development system and the FPGA Module. You create and edit 

FPGA VIs and host VIs on the development computer.

Note The NI Device Drivers installer detects the NI software that is currently installed and 

offers a selection of device drivers based on the components it detects. Both LabVIEW and 

the LabVIEW Real-Time Module installers prompt you to install device drivers as part of 

the installations. If you are installing LabVIEW and the LabVIEW Real-Time Module, you 

can save time by installing device drivers only once after you install LabVIEW and the 

LabVIEW Real-Time Module. If are not installing the LabVIEW Real-Time Module, you 

can install device drivers when you install LabVIEW. 
 
To avoid installing device drivers with LabVIEW, perform a custom installation of 

LabVIEW. On the Features screen, click the icon to the left of the Device Drivers 

component and select Do not install drivers. Refer to step 4 for information about the 

device drivers you need to install.

1. Log in to the development computer as an administrator or as a user 

with administrative privileges.

2. Install LabVIEW 7.0 from the LabVIEW 7.0 installation CD. Refer to 

the LabVIEW Release Notes for information about installing the 

LabVIEW development system.

3. If you also plan to use the LabVIEW Real-Time Module, install the 

LabVIEW Real-Time Module from the LabVIEW Real-Time 

Module 7.0 installation CD. Refer to Chapter 2, Installing and 

Configuring the RT Module and RT Targets, of the LabVIEW 

Real-Time Module User Manual for information about installing 

the LabVIEW Real-Time Module.

4. As part of the LabVIEW or LabVIEW Real-Time Module installation, 

install NI device drivers. The installer selects device drivers 

appropriate for the NI software you have installed on the computer, so 

you will install everything you need to use the LabVIEW Real-Time 

Module and FPGA Module if you choose to install the default 

selection. 

If you choose to modify the default selection, you must install 

NI Measurement & Automation Explorer (MAX) and the following 

components under Instrument Control»NI-VISA:

• Run Time Support

– PXI 

– Remote

• Configuration Support

• Development Support
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You also can install the following components if your application or 

configuration requires them:

• Instrument Control»NI-VISA»Remote Server—Installs the 

NI-VISA Server so other computers on the network can access 

FPGA devices in your development computer.

• Real-Time and Embedded»NI-VISA—Saves the Real-Time 

and Embedded components on the development computer so you 

can download them to the RT controller using MAX.

• Real-Time and Embedded»NI-RIO—Although you can install 

NI-RIO now, you will install NI-RIO in the next step when you 

install the LabVIEW FPGA Module, which installs NI-RIO by 

default.

5. Install the FPGA Module from the LabVIEW FPGA Module 1.0 

installation CD, following the instructions that appear on the screen. 

Select Complete when you reach the Select Installation Type step.

The FPGA Module installs program files, NI-RIO, documentation, 

examples, and Xilinx ISE. Xilinx ISE is installed in the x:\NILVFPGA 

directory, where x is the drive on which you installed the FPGA 

Module. If you uninstall the FPGA Module, you first must manually 

uninstall Xilinx ISE.

Setting up Remote RT Systems with FPGA Devices

If you need to access FPGA devices in remote RT systems, set up the RT 

target as described in Chapter 2, Installing and Configuring the RT Module 

and RT Targets, of the LabVIEW Real-Time Module User Manual, making 

sure you download NI-VISA, the NI-VISA Server, and NI-RIO RT to the 

RT target.

Accessing and Configuring FPGA Devices

FPGA devices might be located in the local development computer or in 

other systems on the network, which are known as remote systems. This 

section contains instructions for accessing and configuring FPGA devices 

in the following systems:

• Local development computer

• Remote systems

– Networked RT system, which is a PXI system with an 
RT controller running the Real-Time Operating System (RTOS) 
and the RT Engine, located on the local subnet

– Networked RT system not located on the local subnet

– Networked Windows computer, which can be a PC or PXI system 
running Windows
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Configuring FPGA Devices in the Local Development Computer
MAX automatically detects FPGA devices installed in the local 

development computer. If you install an FPGA device in the development 

computer, you can locate the device in MAX under the My System» 
Devices and Interfaces category. After you verify that MAX recognizes 

the FPGA device, you can begin developing FPGA VIs in LabVIEW. Refer 

to the Targeting an FPGA Device with LabVIEW section later in this 

document for information about selecting the FPGA device as the 

LabVIEW execution target.

Configuring FPGA Devices in Remote Systems
The FPGA Module uses the NI-VISA communication protocol to locate 

remote FPGA devices, which are detected as VISA resources, and display 

them in MAX. Although NI-VISA has a very rich feature set, you do not 

need to develop an in-depth understanding of NI-VISA to successfully use 

the FPGA Module. As a user of the FPGA Module, you just run the 

NI-VISA Server on the remote system to make FPGA devices installed in 

that system accessible to other computers on the network.

The NI-VISA Server is a tool that enables users on a network to access 

VISA resources on the computer on which the NI-VISA Server is running. 

The NI-VISA Server can run on networked RT targets, located both on and 

off the local subnet, and Windows computers.

Tip Remote systems can access the VISA resources on your development computer when 

you run the NI-VISA Server on your development computer and grant access permissions, 

as described in the Setting Access Permissions section later in this document.

You configure FPGA devices interactively in MAX so you can select them 

as execution targets from LabVIEW. You must complete the following 

general steps before you can target LabVIEW to an FPGA device in a 

remote system. Refer to the following sections for detailed information 

about each step.

1. Make the FPGA device appear in MAX. 

2. Set access permissions to grant or deny access to the FPGA device 

from other computers on the network.

3. Enable remote finding for the remote FPGA device on the local 

computer.
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Making FPGA Devices Appear in MAX
There are three different ways to make remote FPGA devices accessible 

in MAX—one for each type of the following remote systems:

• Networked RT systems located on the local subnet

• Networked RT systems not located on the local subnet

• Networked Windows computers

Complete the steps in the following sections to make FPGA devices appear 

in MAX.

Networked RT Systems on the Local Subnet

1. If you have not already installed NI-VISA and the NI-VISA Server on 

the RT target, download them from MAX. Refer to Chapter 2, 

Installing and Configuring the RT Module and RT Targets, of the 

LabVIEW Real-Time Module User Manual for information about 

downloading software to RT targets.

2. Restart the RT target. The NI-VISA Server runs automatically on 

networked RT targets when you have NI-VISA and the NI-VISA 

Server installed on the RT target. When the NI-VISA Server runs on 

an RT target, the monitor output displays a message that the NI-VISA 

Server started successfully.

3. Find the FPGA device in the Remote Systems category in MAX. MAX 

automatically detects NI-VISA Servers running on networked RT 

systems located on the local subnet. You can locate FPGA devices 

under the Remote Systems»Remote System Name»Devices and 

Interfaces category, where Remote System Name is the name or IP 

address of the remote system.

Figure 1 shows a remote system, named fpga027, that contains 

NI PXI-7831R FPGA devices. Notice that MAX lists the FPGA 

devices using a VISA resource name. In Figure 1, the selected FPGA 

device is identified as PXI1::15::INSTR (PXI-7831R). From the 

VISA resource name, you know that the device is installed in the first 

bus (PXI1) and that the device number is 15.
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Figure 1.  FPGA Device Installed on a Remote System

4. Refer to the Setting Access Permissions and Enabling Remote Finding 

sections later in this document for information about configuring 

access permissions to remote FPGA devices and creating a find list so 

LabVIEW can display available FPGA devices as possible execution 

targets.

Networked RT Systems Not on the Local Subnet

1. If you have not already installed NI-VISA and the NI-VISA Server on 

the RT target, download them using MAX from a computer on the 

local subnet. Refer to Chapter 2, Installing and Configuring the RT 

Module and RT Targets, of the LabVIEW Real-Time Module User 

Manual for information about downloading software to RT targets.

2. Restart the RT target. The NI-VISA Server runs automatically on 

networked RT targets when you have NI-VISA and the NI-VISA 

Server installed on the RT target. When the NI-VISA Server runs on 

an RT target, the monitor output displays a message that the NI-VISA 

Server started successfully.

MAX cannot automatically detect NI-VISA Servers running on 

remote RT targets not located on the local subnet—unlike NI-VISA 

Servers running on RT targets located on the local subnet—so you 

must manually add the remote system.
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3. In MAX on the development computer, right-click the Remote 

Systems category and select Create New from the shortcut menu.

4. Select Remote Device (not on the local subnet) and click the Next 

button.

5. Specify the remote system using the network name or IP address of the 

RT target and click the Finish button.

6. After MAX displays the remote system, locate the FPGA device under 

the Remote Systems»Remote System Name»Devices and Interfaces 

category, where Remote System Name is the name or IP address of the 

remote system, as shown in Figure 1.

7. Refer to the Setting Access Permissions and Enabling Remote Finding 

sections later in this document for information about configuring 

access permissions to remote FPGA devices and creating a find list so 

LabVIEW can display available FPGA devices as possible execution 

targets.

Networked Windows Computers

1. On the remote computer that contains the FPGA device you want to 

access, start the NI-VISA Server by selecting Start»Programs» 
National Instruments»VISA»NI-VISA Server. 

When the NI-VISA Server runs on a Windows computer, you see the 

VISA icon in the Windows system tray, shown at left. MAX cannot 

automatically detect NI-VISA Servers running on networked PCs or 

PXI systems running Windows, so you must manually add the remote 

system.

2. In MAX on the development computer, right-click the Remote 

Systems category and select Create New from the shortcut menu.

3. Select Remote VISA System and click the Next button.

4. Specify the remote system using the network name or IP address of the 

Windows computer running the NI-VISA Server and click the Finish 

button.

5. After MAX displays the remote system, locate the FPGA device under 

the Remote Systems»Remote System Name»Devices and Interfaces 

category, where Remote System Name is the name or IP address of the 

remote system, as shown in Figure 1.

6. Refer to the Setting Access Permissions and Enabling Remote Finding 

sections later in this document for information about configuring 

access permissions to remote FPGA devices and creating a find list so 

LabVIEW can display available FPGA devices as possible execution 

targets.
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Setting Access Permissions
Complete the following steps to allow other computers to access the remote 

system.

1. If the NI-VISA Server is running on an RT target, select the RT target 

under the Remote Systems category in MAX. If the NI-VISA Server 

is running on a Windows computer, open MAX on that computer and 

proceed to the next step.

2. For RT targets, open the VISA Options page by clicking the VISA 

Options tab. For Windows computers, open the VISA Options page 

by selecting Tools»NI-VISA»VISA Options.

3. On the VISA Options page, select VISA Server»Security to view the 

Remote Access List, as shown in Figure 2.

Figure 2.  Setting Access Permissions for Remote Systems

4. Click the Add button, shown at left, to add a computer to the Remote 

Access List and enter the name or IP address of the computer. You can 

use the * wildcard to specify a group of computers or all computers on 

the network. In general, use the * wildcard to set up general allowances 

or denials, and follow those entries with more specific entries. Refer to 

the LabVIEW Help, available by selecting Help»VI, Function, & 

How-To Help in LabVIEW, for general information about access list 

entries and wildcards.
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5. Select a Permission option to either allow access to the remote system 

or deny access to the remote system.

6. Click the Apply button, shown at left, to set the access permissions.

Enabling Remote Finding
You can configure NI-VISA on the development computer to 

automatically search specific remote systems when searching for VISA 

resources, such as FPGA devices. The FPGA Module uses NI-VISA to find 

available FPGA devices when LabVIEW starts so you can select an FPGA 

device as an execution target. You must enable remote finding for an FPGA 

device before you can target the FPGA device in LabVIEW. Complete the 

following steps to create a find list.

1. If you are currently configuring access permissions for a remote 

system, click the VISA Options >> Remote button, as shown in 

Figure 2, to open the VISA Options page for the local VISA settings. 

Otherwise, select Tools»NI-VISA»VISA Options to open the VISA 

Options page and select VISA Settings»Remote, as shown in 

Figure 3.

Figure 3.  Enabling Remote Finding on Specific Remote Systems
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2. Place checkmarks in the checkboxes next to the remote systems that 

you want VISA on the local computer to automatically search for 

VISA resources.

Note Each time you start LabVIEW, LabVIEW searches for FPGA devices on the remote 

systems for which you have enabled remote finding. LabVIEW attempts to query each 

remote system for approximately 40 seconds. If LabVIEW cannot connect to a remote 

system in that time, LabVIEW skips that remote system and moves to the next remote 

system on the find list. If you know that a remote system is not available, remove the 

checkmark next to the remote system in the find list so LabVIEW does not attempt to query 

that remote system.

3. Click the Apply button.

4. Restart LabVIEW so LabVIEW can recognize the new FPGA devices 

and list them as execution targets. Refer to the Targeting an FPGA 

Device with LabVIEW section for information about selecting 

execution targets in LabVIEW.

Targeting an FPGA Device with LabVIEW

With the FPGA Module, you must select the location on which you want a 

VI to run, which is called an execution target. For example, you run FPGA 

VIs on an FPGA device, so you will select an FPGA device as the execution 

target. After you select an execution target, LabVIEW modifies the 

palettes, VIs, functions, and development tools to offer only those that 

make sense for the execution target.

To change the execution target from the LabVIEW dialog box, as shown 

in Figure 4, select an FPGA device from the Execution Target pull-down 

menu. Alternatively, you can switch the execution target from an open VI 

by selecting Operate»Switch Execution Target.
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Figure 4.  Selecting an Execution Target in the LabVIEW Dialog Box

You can create and compile FPGA VIs even if you do not have an FPGA 

device. Select FPGA Device: 78XX (Not Present) in the Execution 

Target pull-down menu, as shown in Figure 4, and develop the FPGA VI 

as you develop any VI. However, if you attempt to download and run the 

FPGA VI, you will receive an error because the device is not present.

You can test the logic of an FPGA VI with traditional LabVIEW debugging 

tools before compiling it by targeting an emulator. To target an emulator 

rather than the FPGA device, select FPGA Device: 78XXEmulator from 

the Execution Target pull-down menu. You must have an FPGA device for 

the emulator to work. Refer to Chapter 6, Debugging FPGA VIs, of the 

LabVIEW FPGA Module User Manual for information about testing FPGA 

VIs with FPGA device emulators.

Getting Started with FPGA VIs and Host VIs

Use the FPGA Module examples to learn about building FPGA VIs and 

host VIs, communicating between VIs running on the FPGA device and on 

the host computer, and programming hardware functionality in the 

FPGA VI. An FPGA VI is a VI that you download to an FPGA device that 

determines the functionality of the hardware using the FPGA Device I/O 

functions. A host VI is a VI that runs in software on the host computer and 

controls and monitors the FPGA VI on the FPGA device using the FPGA 

Interface functions.
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In this section, you will learn to browse the FPGA Module examples with 

the NI Example Finder, download and run an FPGA VI, and communicate 

with an FPGA VI from a host VI.

Browsing Examples with the NI Example Finder
Complete the following steps to browse installed examples with the 

NI Example Finder.

1. Select Help»Find Examples in LabVIEW to browse all LabVIEW 

examples installed on the development computer.

2. Select Directory Structure on the Browse tab to browse the examples 

by directory structure.

3. Browse the examples in the FPGA directory. The FPGA Module 

examples demonstrate a variety of tasks and concepts, including the 

following:

• Performing basic I/O

• Building hardware counters in LabVIEW

• Exploring timing and triggering possibilities

• Communicating between the FPGA VI running on the FPGA 

device and the host VI running on the host computer

You can find information about these topics and more in the 

LabVIEW FPGA Module User Manual. Refer to the hardware 

documentation for information specific to the FPGA device.

4. Navigate to the Getting Started\Interactive -  
IO Primitives.llb in the listbox.

5. Select Digital.vi in the listbox. Notice that a brief description of the 

Digital VI appears in the Description text box. All examples in the 

Getting Started directory contain descriptions to help you find a 

relevant example quickly.

Exploring an FPGA VI
The Digital VI demonstrates basic concepts of programming an FPGA 

device like the NI PXI-7831R using the FPGA Module. Complete the 

following steps to view and run an example of an FPGA VI and verify that 

you correctly installed and configured the FPGA device.

Note You must have an FPGA device available and configured to complete this exercise. 

Refer to the Accessing and Configuring FPGA Devices section earlier in this document for 

information about configuring local and remote FPGA devices.
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1. After completing the steps in the Browsing Examples with the NI 

Example Finder section, double-click Digital.vi in the listbox of the 

NI Example Finder to launch the Digital VI.

2. Because this VI is designed to run on an FPGA device, select an FPGA 

device as the execution target. Refer to the Targeting an FPGA Device 

with LabVIEW section earlier in this document for information about 

selecting execution targets.

Figure 5 shows the front panel of the Digital VI. Notice that the 

execution target appears in the lower left corner of the window.

Figure 5.  Front Panel of the FPGA VI

Select Help»Show Context Help and move the cursor over the VI 

icon in the upper right corner of the window. Notice the Context Help 

window contains information to help you set up and run the example. 

You can use the Context Help window in all FPGA Module Getting 

Started examples to learn how to setup and run each example.

3. Click the Run button. The Digital VI is already compiled to run on the 

the NI PXI-7831R. The FPGA Module determines which VI currently 
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resides on the FPGA device, and if the Digital VI does not exist on the 

FPGA device, the FPGA Module downloads and runs it on the FPGA 

device.

Note If a VI is not already compiled for the FPGA device, LabVIEW compiles the VI the 

first time you target LabVIEW to an FPGA device and click the Run button. Refer to 

Chapter 4, Running FPGA VIs, of the LabVIEW FPGA Module User Manual for 

information about compiling, downloading, and running FPGA VIs.

4. Click the push buttons in the Digital Outputs panel and notice how 

they affect the LEDs in the Digital Inputs panel. For example, when 

you click the DO 14 push button, the DI 14 LED turns on. When you 

click the DO 15 button, the DI 15 LED turns on. However, if you click 

the DO 4 or DO 5 push buttons, nothing happens. DO 4 and DO 5 are 

not configured to write to the same connector pins that DI 0 and DI 1 

read, the behavior of which is documented in the Context Help 

window for this VI.

5. Select Window»Show Block Diagram to view the block diagram, 

as shown in Figure 6. Notice how the indicators and controls are wired 

to the Digital Input and Digital Output functions.

Figure 6.  Block Diagram of the FPGA VI
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Refer to the LabVIEW Help, available by selecting Help»VI, 

Function, & How-To Help, for information about using these and 

other FPGA Device I/O functions in FPGA VIs.

6. Return to the front panel and click the STOP button.

7. Return to the block diagram and double-click the Digital Input 

function icon. The Configure Digital Input dialog box appears. Select 

different inputs in the Preview list and notice how each input is 

associated with a specific DIO pin.

Table 1 shows the mapping of digital inputs and digital outputs to pin 

names on the NI PXI-7831R. Digital Input 14 and Digital Output 14 

refer to the same physical pin—pin 13. Also, Digital Input 15 

corresponds to Digital Output 15. However, Digital Input 0, Digital 

Input 1, Digital Output 4, and Digital Output 5 all refer to different pins. 

Refer to the FPGA device documentation for information about 

connector pin assignments.

8. Click the Cancel button to close the Configure Digital Input dialog 

box.

9. Close the Digital VI.

Refer to Chapter 2, Creating FPGA VIs, of the LabVIEW FPGA Module 

User Manual for information about designing FPGA VIs.

Table 1.  Mapping of Digital Inputs and Outputs on Connector 0 for the NI PXI-7831R

Terminal Alias Connector Pin

Digital Input 0 Pin 36

Digital Input 1 Pin 37

Digital Input 14 Pin 13

Digital Input 15 Pin 47

Digital Output 4 Pin 40

Digital Output 5 Pin 41

Digital Output 14 Pin 13

Digital Output 15 Pin 47

Digital Ground Pin 2
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Exploring a Host VI
The Digital (Host) VI demonstrates basic concepts of communicating with 

the FPGA VI running on the FPGA device from a VI running on a 

Windows computer or networked RT target. Complete the following steps 

to view and run an example of a host VI.

1. From the NI Example Finder, open FPGA\Getting Started\ 

Programmatic - IO Primitives.llb\Digital (Host).vi.

2. Because this VI is designed to run on the host computer, select 

LabVIEW for Windows or an RT target as the execution target. 

3. Click the Run button.

Figure 7 shows the front panel of the Digital Host VI. If you target 

LabVIEW to an RT target, the execution target appears in the lower left 

corner of the window, as shown in Figure 7.

Figure 7.  Front Panel of the Host VI

4. Click the push buttons in the Digital Outputs panel and notice how 

they affect the LEDs on the Digital Inputs panel. The Digital (Host) 

VI behaves the same as the Digital VI in the Exploring an FPGA VI 

section earlier in this document.
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5. Select Window»Show Block Diagram from the Digital (Host) VI 

to view the block diagram. The block diagram appears as shown in 

Figure 8.

Figure 8.  Block Diagram of the Host VI

Notice that the Digital (Host) VI uses the Open FPGA VI Reference 

function to open and run the Digital (FPGA) VI. The image inside the 

Open FPGA VI Reference function icon matches the icon for the 

Digital (FPGA) VI.

The Digital (Host) VI then uses the Read/Write Control function to 

read from or write to the indicators and controls in the Digital (FPGA) 

VI running on the FPGA device. Specifically the Read/Write control 

reads the state of the digital inputs on the FPGA device and allows you 

to change the state of the digital outputs on the FPGA device from the 

host computer.

The Close FPGA VI Reference function closes the reference to the 

FPGA VI. Refer to the LabVIEW Help, available by selecting 

Help»VI, Function, & How-To Help, for information about using 

these and other FPGA Interface functions in host VIs. 

6. Return to the front panel and click the STOP button on the front panel 

to stop the VI. 

7. Close the Digital (Host) VI.
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Refer to Chapter 5, Communicating with FPGA VIs, of the LabVIEW 

FPGA Module User Manual for information about creating host VIs that 

you can use to programmatically interact with FPGA VIs. 

Where to Go from Here

National Instruments provides many resources to help you succeed with 

your National Instruments products. Please use the following resources as 

you start exploring LabVIEW and the FPGA Module. 

FPGA Module Examples
Start with an existing FPGA Module example and use it as a framework for 

your FPGA VIs and host VIs.

From LabVIEW, launch the NI Example Finder by selecting Help»Find 

Examples and browse the FPGA directory for examples. Refer to the 

Description text box for descriptions of the examples to quickly locate a 

relevant example.

Consider browsing the examples by directory in the following order to 

build your knowledge of the FPGA Module.

• Getting Started

• IO Primitives

• Timing and Triggering

• Host Synchronization

• Counters

• Applets

FPGA Module Templates
The FPGA Module offers templates to help you get started quickly. In the 

LabVIEW dialog box, click the New button and browse template previews 

and descriptions to find a template appropriate for your application. When 

you find a template that you want to use, select it in the Create new list and 

click the OK button.

Related Documentation
Refer to the following documents for conceptual information about 

LabVIEW, the LabVIEW Real-Time Module, and the FPGA Module. 

Note You must have Adobe Acrobat Reader with Search and Accessibility 5.0.5 or later 

installed to view the PDFs. Refer to the Adobe Systems Incorporated Web site at 

www.adobe.com to download Acrobat Reader.

http://www.adobe.com
http://www.adobe.com
http://www.adobe.com
http://www.adobe.com
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• LabVIEW FPGA Module User Manual (PDF only)—Information 

about using the FPGA Module to create FPGA VIs and host VIs. 

Select Start»Programs»National Instruments»LabVIEW 7.0» 
Module Documents»LabVIEW FPGA Module User Manual to 

view a PDF of the document.

• LabVIEW User Manual—Information about using LabVIEW to create 

VIs. In LabVIEW, select Help»Search the LabVIEW Bookshelf to 

search documentation for the LabVIEW development system.

• LabVIEW Real-Time Module User Manual—Information about using 

the LabVIEW Real-Time Module to create deterministic VIs. In 

LabVIEW, select Help»Search the Real-Time Module Bookshelf to 

search documentation for the LabVIEW Real-Time Module.

Refer to the LabVIEW Help and Context Help window for information 

about using VIs and functions.

• LabVIEW Help—Available by selecting Help»VI, Function, & 

How-To Help. Browse the FPGA Module book in the Contents tab 

for an overview of the FPGA Module information included in the 

LabVIEW Help.

• Context Help window—Available by selecting Help»Show Context 

Help.

Refer to the following documents, which are available by selecting 

Start»Programs»National Instruments»NI-RIO»Documents, for 

information about the NI PXI-7831R.

• Where to Start with the NI PXI-7831R—Information about connector 

pin assignments and installing the NI PXI-7831R.

• NI PXI-7831R User Manual—Information about the NI PXI-7831R.

NI Web Site
Visit ni.com for the latest NI Developer Zone articles, examples, and 

support information for the FPGA Module.

Known Issues

Refer to readme.txt on the LabVIEW FPGA Module CD for information 

about known issues with the FPGA Module.

http://www.ni.com
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